ud009 ยป

Firebase Essentials - Github Code Issues

Firebase Essentials has a detailed compendium app to the course, ShoppingList++. This app had both before quiz and after quiz states as described here. If you find any issues with the official code before and after states including:

  • Code doesn't compile with a specific version of Android
  • UI errors
  • Unclear instructions

Please report them as described below. We'll be monitoring these forums and updating the codebase accordingly. Thank you for your help!

If you're having issues with your own code, don't use the steps below. Instead please feel free to reach out on the forms by making a new topic about your question. This is specifically for issues with the code that's written in the Github repo.

Reporting a Github Repository Code Issue for ShoppingList++

Use the format below:


Please specify the Github code step where the error originates (e.g. 2.01 The Detail Screen - Quiz. Note that if this is not about code that is in the official repository, please make a new topic in the forums):

Please specify if you are using an emulator or a phone and the model (e.g. Emulator, Genymotion, Nexus 5):

Please specify what OS and Android Studio version you're using to compile your app (e.g. Mac OS 10.9.5, Android Studio 1.4):

What version of the Android OS are you running (e.g. 5.0.1)?

What steps cause the issue?

What erroneous behavior, error messages and/or stack trace do you see?

What java classes or resource files is this related to (if you know)?

Anything else?


For Lesson 1 Github Repository Issues for ShoppingList++ post here

For Lesson 2 Github Repository Issues for ShoppingList++ post here

For Lesson 3 Github Repository Issues for ShoppingList++ post here

For Lesson 4 Github Repository Issues for ShoppingList++ post here

For Lesson 5 Github Repository Issues for ShoppingList++ post here